Opplever delvis strømbrudd

Public Services - TechBin is currently unavailable

Løst
Større brudd
Begynte på 16 dager siden Varte omtrent en time

Påvirket

Public Services
TechBin
Oppdateringer
  • Løst
    Løst

    Public Services - TechBin is currently unavailable, our team has been notified & are working on it as we speak (Automated Notice).

  • Undersøker
    Undersøker

    Public Services - TechBin is currently unavailable, our team has been notified & are working on it as we speak (Automated Notice).